The ability to reply to discussions is limited to PRO members. Want to join in the discussion? Click here to subscribe now.

Set up a killer React dev environment quickly with hjs-webpack

Set up a killer React dev environment quickly with hjs-webpack

6:17
You can easily spend hours configuring the perfect dev environment with all the latest hotness like ES6 (and beyond) support, hot reloading, and a myriad of other features. This lesson shows how to use hjs-webpack to get the same thing in a matter of minutes.
Watch this lesson now
Avatar
egghead.io

You can easily spend hours configuring the perfect dev environment with all the latest hotness like ES6 (and beyond) support, hot reloading, and a myriad of other features. This lesson shows how to use hjs-webpack to get the same thing in a matter of minutes.

Avatar
Mitri

What sublime theme is this?

Avatar
Ben

It's the One Dark theme for Atom. :)

In reply to Mitri
Avatar
Elliot

My package.json file looked absolutely nothing like this. I'm on v 2.14.7, and node 4.2.1. The first time I tried the command you set, I had all of those peerDependency errors, so I npm installed a bunch I found here - https://github.com/henrikjoreteg/hjs-webpack, but I feel like this video is missing a few steps here. For scripts, all I have is: "scripts": {
"test": "echo \"Error: no test specified\" && exit 1"
}

Is there something I'm not doing properly?

Thanks!

Avatar
Ben

Hey Elliott,

It looks like hjs-webpack removed the peerDependencies in v3.0.0. You can either use the instructions they added at https://github.com/HenrikJoreteg/hjs-webpack/blob/master/README.md#optional-dependencies or install a 2.x version via npm i -S hjs-webpack@2.x.

The scripts section of your package.json has to be edited manually.

Ben

In reply to Elliot
Avatar
Amit

Hey Ben,

Great video. Was looking forward to the ease of setting this up but having some errors with transpiling the jsx on my main render to the DOM.

I thought it was something i did but then ran into this issue: https://github.com/HenrikJoreteg/hjs-webpack/issues/93 , which seems to suggest that hjs-webpack does not yet work with babel 6. Any ideas how to proceed?

In reply to Ben
HEY, QUICK QUESTION!
Joel's Head
Why are we asking?